Project

General

Profile

Bug #145

[Kirby Rainbow Curse/Paintbrush] The touch screen continue to receive inputs even when you release the mouse button

Added by Sixel about 3 years ago. Updated over 1 year ago.

Status:
New
Priority:
Normal
Assignee:
Category:
Input
Start date:
07/19/2019
API:
OpenGL
Cemu Version:
1.20.1c
GPU Vendor/Model:

Description

Really annoying input bug that affect the game multiple times.
Basically the brush keeps drawing even when you release the mouse button, which let you finish the ink and disrupt gameplay.

Take in mind that it's an input issue with the game since it randomly holds down the touch screen.
Example: Normally if you touch Kirby he will to a "spin", if you holds down on Kirby he will do a special move.

With this bug it even happen to get the special move when you just want to tap on Kirby, so basically the touchscreen holds down at random times.

I tested Wonderful 101 and I didn't encountered this issue so I think it's a game related bug.

I tried on two different PC with 1.15.9 and 1.15.10, both with native resolution, enhanced resolution or other settings like vsync on/off and GX2Draw on/off, the issue was still there.

Thank you.

History

#1

Updated by Petergov about 3 years ago

do you use a touch device? I can't reproduce that error when playing the first levels.

#2

Updated by Sixel about 2 years ago

Petergov wrote:

do you use a touch device? I can't reproduce that error when playing the first levels.

Hi! Sorry if I respond you only now but I ended up not trying the game anymore and forgot to check the report.
I've tried the game again with the 1.20.1c version and sadly the bug is still there.

I use a regular mouse and you can experience the issue if you draw a lot of lines, so this come up especially in the challenges or when you draw with scrolling levels. Try a challenge or the second level of the first world, especially the part were you have to go up in the tree.

Here a video of the issue:
https://www.youtube.com/watch?v=vqFwB7CpeSI

You can see around 0:09 that I released left click and the line was still going on. This is the issue I'm talking about. Sadly you can see from the video that this recent Cemu version introduced a new bug too so the lines randomly disappear but I guess it's better talk about that in another report but yeah, I hope the video can help to figure out what's happening, thank you :)

#3

Updated by Serfrost over 1 year ago

  • Cemu Version set to 1.20.1c

Also available in: Atom PDF