Project

General

Profile

Bug #629

Mario Tennis: Ultra Smash crash at main menu

Added by hexaae 3 months ago. Updated 20 days ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
General
Start date:
03/24/2022
API:
OpenGL, Vulkan
Cemu Version:
1.26.2f
GPU Vendor/Model:
GTX 1070 8GB

Description

Moving around in main menu (after you press button A, those animated tiles...) makes CEMU frequently crash. It's 100% reproducible for me just moving around between animated tiles for 10-30secs.

Tested with: OGL and VK, no cemuhook dll installed, tried CPU single, multi, auto, online account=off.
Crash dump: https://1drv.ms/u/s!ApMUGr0cuN39gokP53_3hPKisyadOQ?e=3MJFH8

Gaming laptop ASUS GL703GS, Win 10, i7-8750H (6+6 cores), NVidia 1070 8GB, 32GB RAM, 1920x1080 144Hz G-Sync laptop screen, NVMe + SSD


Files

mainmenu.jpg (669 KB) mainmenu.jpg cooxie1234, 04/28/2022 06:55 AM

History

#1

Updated by Exzap 3 months ago

  • Status changed from New to In Progress

This is caused by a bug in the new video decoder. The next Cemu release should have a fix for this.
As a workaround you can use Cemuhook's H264 decoder for now.

#2

Updated by hexaae 3 months ago

Thank you for quick reply.
I just tried with cemuhook.dll and keystone.dll in CEMU.exe dir, but doesn't fix this game.
No prob anyway: I'll wait for the next CEMU build.

#3

Updated by Exzap 3 months ago

You have to turn it on in the menu under debug -> Use Cemuhook H264

#4

Updated by hexaae 3 months ago

Thanks! Wasn't specified on Cemu hook installation instructions.

#5

Updated by cooxie1234 2 months ago

Issue still present on experimental 1.27.0
There are also some artifacts in the main menu with demuhook H264 disabled. See the edges in attached screenshot.

unrelated - Bug #580 still present on experimental 1.27.0

#6

Updated by hexaae 2 months ago

I can confirm it's still present in 1.27.0 Exp.

#7

Updated by Exzap 2 months ago

Enable debug -> accurate barriers and let me know if that fixes the artifacts

#8

Updated by cooxie1234 2 months ago

Exzap wrote:

Enable debug -> accurate barriers and let me know if that fixes the artifacts

Yes. Fixes the artifacts.

#9

Updated by hexaae 2 months ago

After I ran it twice (it still crashed first time, maybe a caches thing...) it's now working fine with 1.27.0b and doesn't crash anymore at the tiles menu.

#10

Updated by hexaae about 1 month ago

Still a bit buggy though: sometimes Tiles animation get stuck until you change tile.

#11

Updated by hexaae 20 days ago

Fixed with 1.27.1.

#12

Updated by Exzap 20 days ago

  • Status changed from In Progress to Closed

Also available in: Atom PDF